April 10th, 2014

green leaves

Passwords you need to change

http://mashable.com/2014/04/09/heartbleed-bug-websites-affected/

The very short version: a number of very respectable major websites had a security flaw which made them quite vulnerable. Now that they've fixed the flaw you should change your password for those sites.

A lot more detail.

Links thanks to andrewducker.

This entry was posted at http://nancylebov.dreamwidth.org/1044315.html. Comments are welcome here or there. comment count unavailable comments so far on that entry.